Informācijas Tehnoloģijas

WAMPserver 2.1 uz Windows Vista

Pavisam nesen uzinstalēju Windows Vista (bussines) 64-bit OS (operētājsistēmu) {lai piedod unix/linux}.
Lai atjaunotu zināšanas PHP valodas lietošanā, tad uzinstalēju WAMPSERVER 2.1.

1. Wampserver nedarbojās, kur ieguvu paziņojumu, ka nepieciešams uzinstalēt attiecīgu kompenenti (vēlāk norādītajā rakstā arī tās nosaukums pie 1.problēmas izklāsta). Uzinstalēju, sāka darboties.
2. Atverot interneta pārlūkprogrammā adresi http://localhost vai http://127.0.0.1 ieguvu neapmierinošu rezultātu, jeb nerādīja WWW mapes index faila izveidoto saturu.

Risinājums tika atrasts: http://james-moodle.blogspot.com/2012/03/looks-like-wamp-it-is.html.

Pirms tam tika apskatīti gan http.conf, gan host faili, par kuriem tika runāts citos iespējamā kļūdas novēŗšanas aprakstos, bet tas viss izrādījās velti.

Šoreiz no augstāk minētās lapas, tika uzzināta jauna iespēja, līdz kurai prāts neaisniedzās – iziet WampServer konteksta izvēlni un izskatīt visas iespējas, tad redzētu, ka Appache serveris nemaz nestrādā!

Viss izrādījās tik vienkārši! Lai gan, lai atrastu šo vienkāršo risinājumu, vajadzēja atrast ierakstu par WampServer pārvaldnieku Sistēmas notikumu žurnālā. Tādā veidā ieguvu atslēgas vārdu, kurš atrada man derīgu problēmas risināšanas veidu.

Tagad atliek atvērt PHP grāmatu un pakustināt pirkstiņus 😉

Advertisements

FreeBASIC instalēšana Ubuntu vidē

Centīgi cilvēki nodarbojas ar programmēšanu BASIC valodā. Un tā kā galvenajam aktīvistam ir OS Ubuntu (linux), tad no tā izrietošas sekas.

Internetā var atrast FreeBASIC instalēšanas failus un izejas kodu arhīvus. Bet, kad strādājam ar Linux kastēm, tad tā lieta reizēm neiet uz priekšu.

Protams, arī manas zināšanas šajā laukā nav pilnīgas, bet rezultātā tiku pie grafiskas (IDE) vides, kurā var nokompilēt un izpildīt BASIC valodā sarakstītu programmas kodu.

Tad nu soli pa solim, kā man tas (un kas) izdevās:

1. Lejupielādēju FreeBasic linux arhīvu no lejupielādes lapas, kurā atradīsiet sev nepieciešamos dokumentus.

2. Atpakoju arhīvu (to var darīt jebkurā lietotājam derīgā/pieejamā vietā).

3. Atvēru termināli un izpildīju komandu: “sudo ./install.sh -i”.

4. Pievienoju nepieciešamās pakotnes:

4.1. 9.04 (Jaunty) Konsole
sudo aptitude install libncurses5-dev libstdc++6-4.3-dev build-essential
4.2. 9.04 (Jaunty) Grafiskajām programmām
sudo aptitude install libX11-dev libXext-dev libXpm-dev libXrender-dev libXrandr-dev
4.3. 7.10 (Gusty) Konsole
sudo aptitude install binutils linux-libc-dev libncurses5-dev libstdc++6-4.1-dev build-essential
4.4. 7.10 (Gusty) Grafiskajām progrmammām
sudo aptitude install libX11-dev libXext-dev libXpm-dev libXrender-dev libXrandr-dev
Ja Jūs neesat uz Gutsy un saņemat kompilatora kļūdu paziņojumus par neesošu -4.5. lsupc++, tad nepieciešms izpildīt sekojošu komandu:
sudo aptitude install libstdc++6-dev

5. Kompilēt programmas kodu
fbc /ceļš/līdz/failam/faila_nosaukums.bas

6. Izpildīt programmu?
faila_nosaukums

?. kad izpildīju Hello programmu, prasīja pieinstalēt Hello pakotni, ko arī izdarīju !!??

p.s. izveidoju gan 1_uzdevums, gan rindu_skaits (pēc idejas izpildāmus failus, bet nestrādā? 😦 )

Noskatoties video līdz galam:

1. System -> Administration -> Synaptic Package Manager
meklē pēc atslēgas vārdiem:

  • geany
  • freebasic

Izrādās Geany – IDE, kas der arī BASIC programmas kodiem!
Geany programmā atvēru savu 1_uzdevums.bas, nokompilēju, nekādu kļūdu, izpildīju un tur viņš strādā, kā vajag.

Grūti pateikt kāpēc consolē nestrādāja!

Varu pateikt, ka eksperimentāli (pēcāk Googliski) konstatēts, ka FreeBASIC Geany IDE nestrādā uz Ubuntu 12.04! Neizdodas piedzīvināt libfreebasic pakotni. Jāpiebilst, ka iedarbināju to visu uz Ubuntu 10.04.

Avoti:

Varbūt vērts izskatīt video šajā lapā, kur pēc stāstītā un redzētā Geany strādā Ubuntu 12.04 versijā.